L ecture 3: Microwind

CSCI 5330
Digital CMOS VLSI Design

Instructor: Saraju P. Mohanty, Ph. D.

NOTE: The figures, text etc included in slides are borrowed
from various books, websites, authors pages, and other
sources for academic purpose only. The instructor does
not claim any originality.
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Lecture Outline

e Microwind Tool
e DCSH Tool
Silicon Tool

Source:
1. http://www.microwind.orq

2. Microwind Based Design (http://vsp2.ecs.umass.edu/vspg/658/
TA_Tools/microwind/Microwind.html)
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http://www.microwind.org/

Microwind and DSCH

 Microwind is a tool for designing and simulating circuits
at layout level. The tool features full editing faclilities
(copy, cut, past, duplicate, move), various views (MOS
characteristics, 2D cross section, 3D process viewer),
and an analog simulator.

« DSCH is a software for logic design. Based on primitives,
a hierarchical circuit can be built and simulated. It also
Includes delay and power consumption evaluation.

e Silicon is for 3D display of the atomic structure of silicon,
with emphasis on the silicon lattice, the dopants, and the
silicon dioxide.
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Microwind and DSCH ...

* Download the followings from
http://www.microwind.org/
—Microwind3
—DSCH3

— User Manual: http://intrage.insa-
toulouse.fr/~etienne/microwind/manual lite.pdf

e |nstallation and Use:

—Unzip the files above to be able to work with
Microwind.

— Read the reference manual for the software.

—Double click on Microwind3.exe to start the layout
editor or on Dsch3.exe to start the schematic editor.
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http://www.microwind.org/
http://intrage.insa-toulouse.fr/~etienne/microwind/manual_lite.pdf
http://intrage.insa-toulouse.fr/~etienne/microwind/manual_lite.pdf

Tools from Microwind

http://www.microwind.org/
 Microwind
e DSCH
 Microwind3 Editor
e Microwind 2D viewer
e Microwind 3D viewer
* Microwind analog simulator
 Microwind tutorial on MOS devices
* View of Silicon Atoms
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Microwind and DSCH : NOR Example

 We will learn both the design flow and the CAD
tools.

 The specifications we are going to see may be
different for different foundry and technology.

e Design Example (3 Levels) : NOR Gate
— Logic Design
— Circuit Design
— Layout Design
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Microwind / DSCH NOR Example: Logic

BHDsch2 - example | _ O]

. op_en the Sc_hemgtic —m - s
Editor in  Microwind
(DSCH3). Click on the
transistor symbol in the
Symbol Library on the o ||
right. o

e Instantiate NMOS or -
PMOS transistors from
the symbol library and
place them in the editor

window.

A N R

Loaded C:A\Dech 2. 05E xporths EEE Shmoz, 5%
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Microwind / DSCH NOR Example: Logic

e Instantiate 2 NMOS and 2 e Connect the drains and
PMQOS transistors. sources of transistors.
=] BN R 5 M=) E
== rﬁgﬂgﬂamn ATL-n |l @ 8 % % 0k EE® XPF LB AL WAL % Hm

PHOE S - [

e e o n

L
T
A
T
L
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A
[ I

Click at 55,25

pazte beginning...
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Microwind / DSCH NOR Example: Logic

e Connect Vdd and GND < Connect Iinput button and
to the schemattic. Qutput LED.

BHDsch2 - example M=l %

File Edit Inzet “iew Simulate Help k
EEHD xR P LSO AL WSS %% D E EHD WP L LIRop AL W& R %

=10 x|

X

Basic I Ardvanced ]

Basic l Adanced ]

) g &

B8 EE D e

-
#
i
B

Lﬂ mas nmos

A
[ I

i

Click at 95.4 Editing "example.sch”
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e YOu now have NOR
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Microwind / DSCH NOR Example: Logic

4 Dsch2 - example.sch
File  Edit [nzert Wiew ﬁimul Help

schematic ready.

Use your logic simulator to
verify the functionality of your
schematic.

The next step Is to simulate
the circuit and check for
functionality.

Click on, Simulate -> Start
simulation.

This brings up a Simulation
Control Window.

Click on the input buttons to b | e et [ Sew gy
v ‘wie state [~ Pinwvalue [ DRegs [ Debug

Set them to 1 Or O- Red COIOr |H‘unning,ahmlutetime=5550.DDDns;EF'LI time=—=
In a switch indicates a 1.
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Microwind / DSCH NOR Example: Logic

e Inputs: 00 e Inputs: 01
. _glx] i =10] x|
> @ [w P F %0 Al wee2 & b o B\ FesmanalsHadssnE

L]

ing, ahsolute ime=5RA0.000ns; CPL time= Running, abzolute time=4560.000ns; CPU time=101=
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Microwind / DSCH NOR Example: Logic

e Inputs: 1 0 e Inputs: 11

5 Dsch2 - example_sch

i54 Dsch? - example_sch
File Edit Insert “iew Simulate Help F|Ie Edit Insert  View Slmula Help

5 H B w P L SR A L S QD% B 5 EHD | w P F L% Rop ALy @R O 2% M

[] []

b o

Running, absolute time=E0E0.000ns; CPU time= 1

Running, absolute time=6220.000ns; CPU time= 1
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Microwind / DSCH NOR Example: Logic

« The simulation output can be observed as a waveform after the
application of the inputs as above. Click on the timing diagram icon in the
Icon menu to see the timing diagram of the input and output waveforms.

Timing diagrams of example.sch
Quit Yiew sl Help
L < Onsidive i} 0.0 BO.O0 100 15000 2000 2800 3000 3500 4000 4500 5000 68500 6000 BROC
== | Lmolowmdwnbmoetmoutmowbomednmodmombmoadnmafammdnomad
ST T - N R N N S S
e o I s e NG W W
SR e = s s S TN S o S WU N N
S5 (20 NSRRGSR SN NSRS NN UNNUNCS NSNS SRRt RSt U UUUOY SR
Maﬂ current n I:II:II:Irrv’-'«
Lis " """ """ Awq curment 0.000ma |77
D80 oneemmeede e P dissip, 0000 |-
A0 o o
1 0{u [ SRS ) U SNSRI SNRUUI SN SRR NSRS SRS ISR SR SONRRNS SRR SRR SO
A/ IO N RSN UL SN SUNON SNSRI AN AN AN AN AN AR AN A
|Eur$0r at time [0.0ns |Supply 2 B0y |Maﬂ. current 0000 |F'nwer dizzip. 0.000r
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Microwind / DSCH NOR Example: Circuit

e Simulate your system with
your hand  calculated

tranS|stor sizes.

FI Edit Insert ‘iew SmIHIp

e H 3w P F S0 AL @

e 2 % Olim
B

ing, absolute time=5880.000ns; CPU time= 155s

e Click File -> Make Verilog
File. The Verilog,
Hierarchy and  Netlist
window appears. This
window shows the verilog
representation of NOR
gate. Click OK to save the
Verilog as a .txt file.

£ =0l
Yerilo lHl rarchﬂ Medl ]
i Hz.2 Werilog Description
44 afzasol " Hisrarchy Verilog
Gt G ECOEE: 1 & FlatVeriog for Microwind2
module exsmple | ]
put inl, in;
pu ut 2 Informatior
wire iOwl:
nmos mweosl (ow I Module n. [8 char. |
nmos mmosSZ (0w e | examp =
oS 1(ouw 20
pmos pmosz (i0wl,vdd, inl) ; . .
endmodule [V Append simulation inl fornations
(A R e CT e T The Verilog fle has 17 lines
I
I The design includes 9 spmbols

UNIVH{bl IY,r
NORTH TEXAS

CSCE 5730: Digital CMOS VLSI Design




(€

Microwind / DSCH NOR Example: Circuit

« Open the layout editor < Click on Compile ->
window in  Microwind. Compile Verilog File. An
Click File -> Select Open Window appears.
Foundry and select X.rul. Select the .txt verilog file
This sets your layout saved before and open it.
designs In X technology.

FI Wiew Edit Simulate  Chdnpile  Analysiz  Help File  View Edit Simulate Compile  Analesic Help

|a-|'r@JqQ-|:;. 2B R ATEH 3 |a|nfrg&>o\-|;t. |m°ﬂ.ﬁ|a11é»u|< >

.J _I _I |__| .......

pl bt
r ddt t ux2Kbd |
Z] FaroutiFasttet  [E] nioilab b=t
Fanoutdtst  [E] e . .
Invertertst [E] ubd. bl

| Filesoftype: [ Text Files [~tat) > e |
[T Dpenasgeadonly N

Mo Errar CMOS 0.18pm - |

Mo Errar CMOS 0.18pm - |

The current technology is "CMOS 0.18pm - 6 Metal”, power supply 2004 Load werilog file C:\Dsch 2.05Exporthexample. st
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Microwind / DSCH NOR Example: Circuit

« After selecting the .txt file, < Click on Size on the right
a new window appears top menus. This shows up
called Verilog file. the NMOS and PMOS

sizes. Set the sizes
according to choice.

W DSCH 223, Flat Verilog ] Size | Labels Routng | DSCH 223, Flat Verilog 7] S |Labels | Routing |
1 8/23001 5:34:07 PM Routing layvers 1 8/23001 5:34:07 PM —Mos size (U
I example.sch I example.sch
’7f" hetall i etal2 wWidth P |1 600
module examplefini,in2 out); = hetal2iMetald module example(int, in2out);
inputint,inZ; inputint,inZ; Length P IU-QUU
output out; ) output out;
weire 0wl E I Add Vertical bus weire 0wl Wifidth M 0.400
nmos nmost{outyssin2), 0 e, nmos nmos1{outyss in);
NmMos nmos 2(outyss,int); I:‘ ™ Add 110 Pads NmMos nmos 2(outyss,int); Length M IEI.EDD
pmos pmost {out 0wl in2); pmos pmost {out 0wl in2);
- Wdd Ve |1 -
< ;I_I < ;I_I
W Limit row width to
| [2000 urm =
Compiler Status

Compiler Status
Compiled cells : 074

Compiled cells : 074
Routed wires : 0

Routed wires : 0
Fads : 0

Fads : 0
Mo error

Mo error
-
i | i

o~ maEEEEEE

b Complle 1 show gridl " Backio editurl off | & Help | B2 compile | e Show gridl " Backio editurl off | & Help |
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Microwind / DSCH NOR Example: Circuit

e Click Compile and then Back < Add a capacitance to the
to editor in the Verilog File output of the design. The
Window. This creates a  value of the capacitance
layout in layout editor depends on your choice.
window using automatic
layout generation procedure.

File Wiew Edit Simulate Compile Analysis Help

s s &Q|:;./|w£4ﬂ|A1té»u|< >

" | Virtual R.L.C Parameters

ararneter
Value |n.015| pF

L
|

Enter a fixed valve (e 51 in
BF to foad the line with 2
capacitance fo ground.

W oK | x Cance

4722 pm CMOS 0.18pm - |

Compiling compl lete, Mo emor
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Microwind / DSCH NOR Example: Circuit

e Click on OK. The e Click on the label marked Inl1. A

capacitance is shown on window appears. Click on the

Pulse option in the window. Insert
the left bottom corner a 01 sequence for that specific

with a value of 0.015fF. input and click on Insert. Then

click on Assign. Perform this
assignment on the other inputs.

- Microwind 2 - Example.msk
Flo View Edi Smubte Compie Anebsis Help

|aﬂf?@&kqﬂa 2B R ATEH S

- Microwind 2 - Example.msk
FIV Edit Simulate Compile Analysic  Help

|EIM?@&TQM& M#ﬂﬁh1£ahp
10 lambda - . . . . . . . . . . . . . . . . . .

10 lam
oum |Add a property [ <]

| Label name: |2

DG Supply| Glock Pulse | Sinus | variable | Ground |
| FParameter
Lewvel 0 ()

- TR
] 01 seq: IDD11DD11
] Il Insert | 1

B e B = sE = W8 - -

ChospR .
dbi=0.431 CMOS 018um - -

dhi=0.035 CMOS 018um -

Period 4.000 nz, frequency 0250 GHz
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Microwind / DSCH NOR Example: Circuit

o Click Simulate -> Run simulation. A simulation window appears with
Inputs and output, shows the tphl, tplh and tp of the circuit. The power
consumption is also shown on the right bottom portion of the window.

* |If you are unable to meet the specifications of the circuit change the
transistor sizes. Generate the layout again and run the simulations till

you achieve your target delays.

Inmos1_0L vl

il | Evaluate
— I
B8 | Frequency

Inmos']_oL vI

Time Scale——

|5 ns vl

Step (ps)
|U.5uu
ore
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Microwind / DSCH NOR Example: Layout

« Design the layout ¢ Vdd and GND rails are of
Metall. The top rail is used
as Vdd and the bottom one
as GND. Click on Metal 1 in
the palette and then create
the required rectangle in the
Iayout window.

. Microwind 2 - C:\mw2\lablnor MSK
File View Edt Simulate Compie Analsis Help

B4 &O\QR{M'.;./HT#_“.'E;H Elévlzl|<:>

manually

« Open the layout editor
window in  Microwind.
Click File -> Select
Foundry and select X.rul

The . h |gy . CMS n1au Betal poar spp\yZ.U — No rrrr MDSD.1Em- ‘ = ""”‘hda i rli1 WS - CMOSD16un- 4F

[ UNIVH-LSMY; . |
CSCE 5730: Digital CM VLSI D n =
( INORTH TEXAS >730: Digital CMOS VLSI Desig i



Ml rowind 2 - C:\mw2\lablnor M5K
File “iew Edit Simulate Compile  Analysis

Microwind / DSCH NOR Example: Layout

« The next step is to build
the NMOS transistors.
Click on the transistor
symbol in the palette. Set
the W, L of the transistor.

Hlp%

'F@ &o\e\-|:;t. EEE K 11@»@:@@@:&
R ¢ 2T
. Mos Parameter Options
. Metal &
B etz B
-
. ETER
B retsz [l
B Metal 1 i
. ~Type Option Init: . o

% n-Channel ’7(" lowy leakage i '

. Palysilicon 2 .
= p-Channel " high speed - [ ]
olysilicon

B - Cittuzion [
B 1+ Dittuszion [l
B el ]

DRC Errars CMOS 018pm -

] "IZIIZI.urn: Pads | Inductnr' Contacts  MOS |Path I Logn I Bus I

width MOS
|2— . g drai

Length MOS

Mbr of Gates
[ Add metal2 to drain

B with buried nwenl © high voltage

XK AR KRR

e Then click on Generate

device. The source of the
transistor IS connected to
the GND rail.

. Microwind 2 - C:\mw2\lablnor MSK
Fie View Edt Simulate Compie Andsis | Help

|BI\T?@ &O\e\l|'.;l. 2B A TEE 2

Mo design nile error. Congratulations [0.4% memary used) Mo Errar CMOS 018pm -
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Microwind / DSCH NOR Example: Layout

 Create another NMOS and
place it in parallel to the first
NMOS device. We share the
two devices' drain diffusions. A
DRC check can be run by
clicking on Analysis -> Design
Rule Checker

“Microwind 2 - C:A\mw2\labTnor MSK
FI Wiew Edit Simulate Cmpl Analysiz Help

 The next step is to place
two PMQOS transistors in
series.

-~ Microwind 2 - C:\mw2\lab1nor. MSK
FI Wiew Edit Simulate Empl Analysiz Help

|am5r@&ﬁquMJwﬁiﬂp1£anﬂﬂw@

e ——— |—_ L e . [T
ALV P
............................ s
............................ Metal 6 F
Metal 5 B
............................ Metsl4 B
............................ Metal 3 [
............................ Metal 2 .
............................ e &
O it
............................ Palyzilicon 2 .
= . Palyzilicon .
P+ Diffuzion [

............................ ri+ Diffusion [l
............................ I il I:‘

Error Ch0S 0.18pm -

AR TR

Show palette menu. .

|aﬂfr@&qqn&/

[ET Fads | |nduct0r| Contacts MOS |Path | Logo | Bus | TR v <

hMos Parameter Options
Metal 6 F
i |16 lambda
Width MOS . o =
ral
Lenath MOS |2 lambda
b of Gates |1

I~ Add metal2 to drain

Metal 4 B8
Metal 3 [
metal 2 [l
hhetal 1 i
Cortact
Palyzilicon 2 .
I~ it buried nyvel) | £ high voltage ':Ii::z::on :
ri+ Diffusion [l
H el O

~Type Qption
" n-Channal © low leakage

& p-Channel  high speed

(€
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Microwind / DSCH NOR Example: Layout

* Place the PMOs transistor on , The

- next step is to
layout close to the Vdd rail on the f the i t 1 th
top. To construct two PMOS connect the Inputs ana tne

transistors in series, diffusions are output of the two
shifted to a side and another poly transistors.
line is added as second transistor.

The diffusion is shared to save
area and reduce capacitance.

M crowind 2 - C:\mw2\lablnor. M5K
File “iew Edit Simulate Compile  Analysis Help File “iew Edit Simulate Co pI Analyziz  Help

\Tr&qqn|:;./|o:ﬂ.ﬁ|A11é»u|<:» o H P e QS W H e |o°ﬂﬁ|g1té»ulgﬂwma

. T e e NEmER - __L_M__m_

M crowind 2 - C:A\mw2\lablnor. M5K

XKD TR A

Mo design nule error. Congratulations (0.7 memary used) Mo Errar CMOS 018pm - Show palette menw Na Ermror CHMOS 0.18pm -
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Microwind / DSCH NOR Example: Layout

« The next step is to connect

e Poly inputs are connected  the poly to metall and then

e Metal output is tometal2. The first symbol in

connected. the first row of the palette is
the poly to metall contact.

-~ Microwind 2 - C:\mw2\lab1nor. MSK "~ Microwind 2 - C:\mw2\lab1nor MSK
FIV Edit  Simulate  Compile  Analysis p FIV%dtSItCD\AI}I Help

|E-\vr@®qq-|:;. |°#£’.'E;|A1E>EI|EEE|E|¥ |E-\Fr@&qqn|;. |oﬁﬂﬁ|A11é»unmwF:a
sred: . ORS00 H EEpI—. . .

................... ++ 1N ve

Dptions

.....

..... P

..................... Metols B
..... . R | o IR
..... T N iz W
..... e e

Contact

..... . . ot el - - - - Polysilicon 2 .
& & e —
""" : : Polysilicon
.......................... e
..... . . N |-+ Ciffuzion [l
..... . . . . . . . . . . . . | . . . . . . . . I Wl I:‘

DRC Errars CMOS 018pm -

XK AR KRR
XK AR KRR

Show palette menu Show palette menu Mo Errar CMOS 018pm -
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Microwind / DSCH NOR Example: Layout

« Then we connect the * The next step Is to
metall to metal2 contact connect the  output
to the previous contact. Metall to Metal2. Once
This is the 4th contact on again use the 4th
the first row. contact in the first row.

-~ Microwind 2 - C:\mw2\lab1nor. MSK
FI Wiew Edit Simulate  Compile  Analysis Help

-~ Microwind 2 - C:\mw2\lab1nor. MSK
FI Wiew Edit Simulate  Compile  Analysis Help

famhda . .  SEEEEEEE grﬁmﬂq(: e

famhda . .  SEEEEEEE grﬁmﬂq(: e

aaaaa

aaaaa

..............

....................................................

aaaaaaaaaa

CCCCCCCCCC

XK AR KRR
XK AR KRR

Mo Errar CMOS 018pm - Show palette menu Mo Errar CMOS 018pm -
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Microwind / DSCH NOR Example: Layout

« Now we connect metal2 to the two inputs and one output
and bring them to the top to go out of the cell.

e Observe the two inputs (left & right) and an output (middle)
above the Vdd ralil in dark blue color.

.~ Microwind 2 - C:\mw2%lab1nor MSK

FI Wiew Edit  Simulate I:ompl Analyziz  Help k

‘Bl||7?‘@ &RQI|&/\J£E>E;|A1EE|<¢>

|Saved 55 boxes in "C:hmw2bab1 non MEE" |Ma Error |ChOS 0.18um -
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Microwind / DSCH NOR Example: Layout

« Now we label the inputs and output as Inl, In2 and out.
Click on Add a Pulse Symbol in the palette (5th from the
right in the 3rd row). Then click on the metal2 of one of the
iInputs. A window appears. Change the name of the input
signal. Insert a 01 sequences and click on Insert. The click

on Assign. Similarly assign the 2nd input a pulse.

'-.:"-Hicmwind 2 - C:\mw2\lab1nor. MSK O] x| '-.,:"-Hicmwind 2 - C:\mw2\lab1nor. MSK
File “iew Edit Simulate Compile Analyzsiz Help File Wiew Edit Simulate Compile Analysii}ﬂelp

B |sPE &0 M A8 R ATER (3
Sy faddapuse B
0A00pm

IL Insert ll
" hssign | x Cancel | IV wigible in simulation - .

Add text Min2"', visible at location 22 81 Mo Errar CMOS 018pm -

Mo existing text here Mo Errar CMOS 018pm -
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Microwind / DSCH NOR Example: Layout

 Now select the Visible Node symbol from the palette (7th
In the third row). Select it and click on the output. The 'Add
a Visible Property' window appears. Change the label
name to out. Select Visible in Simulation. Click on Assign.
Now the output is also labeled.

ER\ w2ilablnor. M5K
FI Wiew Edit Situlate Compile  Analpzis  Help

|B-\Fr@ &te\l|;l. 2B R A TEE (3

- Microwind 2 - C:\mw2\lab1nor. M5K
FI Wiew Edit  Sim IRC pie  Analyzis  Help

|B-\Fr@ &te\l|;l. |_s.e_n.ﬂ|a TR 3

ulse I Sinug Variable | Gruundl

Add a tick in "Visible in simulation” to see the
sighal waveform at the next simulation

Mo existing text here Mo Errar CMOS 018pm -

R
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Microwind / DSCH NOR Example: Layout

« Select Vdd Supply and GND from the « To run the Simulation of your
palette (third row). Also click on the  cjrcuit, click on Simulate -> Start

capacitor (3rd in 2nd row) symbol and Simulation. Depending on the input

add it to the output. Also, extend the p- - :
well into the Vdd Rail. The click on ~ Scduences assigned at the input
the output is observed In the

Edit -> Generate -> Contacts. Select _ . :
PATH and then in Metal choose simulation. The power value is also

Metall and N+ polarization. given.

Microwind 2 - C:\mw2\lab1nor. MSK =
-2 Simulation of C:Amw2\lablnor HSK

File “iew Edit Simulate Compile Analysiz Help
S RN e
§lambda

e
0.500pm - )

5 [=]
Displa
¥ Delay
I Gain
between...

215 =
5| 5|2
= ;
5
s
‘ ‘

|
m
=

I Minhtax
W Freguency

|0ut j

Time Scale

J

ins -

oompERE

“oltage vs. time Avoltages and currents AVoltage ve. voltage AFrequency vs time

dh=2.017 CMOS 018um -

Redraw C:hmw2iablnor. MSK (62 boxes)
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More Reading from Microwind Site

http://Intrage.insa-toulouse.fr/~etienne/microwind/docs.html

* Introducing basic design rules. MOS design
rules, interconnect design rules, supply design
rules.

 Technology influence on design rules resistance
effect, capacitance effect, propagation.

« Specific design rules salicide, Idd, antenna ratio,
matching, supply rules, ESD.

* |Introducing CMOS 90nm technology

* A very simple four-bit microprocessor designed
and simulated at gate level with DSCH3

UNIVERSITY,r o |
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